1

Closed

Programs not getting managed/dissapear completely

description

I'm having issues with some of the programs I'm using.
They don't show up in the taskbar, disappear from the alt/tab menu and they don't get tiled although I'm running windawesome elevated.

I uploaded two video files which demonstrate the issues:

Video 1: Foobar disappears and teamspeak doesn't get managed by windawesome.

Video 2: Starting Foobar when windawesome is already running. Foobar gets tiled perfectly fine when I run a webbrowser, but if I open a folder in the windows explorer it disappears again.

Thanks for any help - Donherberto.
Closed Jan 15, 2015 at 11:50 AM by Alien282

comments

Alien282 wrote Jan 1, 2015 at 2:00 PM

Hi, sorry for the delayed answer. The problem with Teamspeak is an issue, yes. I will try to figure it out soon. The thing about Foobar - I think you've missed the concept of workspaces. :) As you see at the top bar, there's some numbers there - that's your workspaces. And if you haven't changed the default settings, Foobar is sent to workspace 7. When you launch Explorer in the second video, it gets sent to workspace 1 (because of one of the rules) and Foobar (and Chrome) stay in workspace 7. But your view goes to workspace 1, that's why you stop seeing Foobar and Chrome. The same thing for video 1.

Anyway, the issue with Teamspeak is real and I will try to fix it soon. No promises though. :)

donherberto wrote Jan 2, 2015 at 8:39 PM

Thank you for the help, I should have had a closer look in the config before asking.

Alien282 wrote Jan 4, 2015 at 2:05 PM

Hi, you could try adding the following program rule:
    ProgramRule(
            className = "Qt5QWindowIcon"
    ),
In the program rules config file BEFORE the entry for the WS_POPUP windows. The problem is that this TeamSpeak window has that style and is not handled by Windawesome by default. If you add this rule it should work.